Помогите с датчиком отпечатка пальца

датчик перестает работать, если если зелёный провод в 3ий пин вставить

На датчике эти провода как подписаны?

RX и TX

Подключать нужно крест на крест: RX <-> TX, TX <-> RX

SoftwareSerial инициализирован на пинах 2 и 3 (rx и tx), соответственно к пину 2 нужно подключать вывод TX датчика, к пину 3 - вывод RX. Подключено так?

Да, если подключить наоборот датчик перестает работать(светиться)

“Во всех руководствах написано, что используется белый и зеленый, но это не так, данный девайс подключается по белому и желтому”

И еще, питание у него от 3,3 вольт

От 3.3 он у меня не питается, но с проводами попробую

Капец, все провода перепробовал, 3 скетча скомпилировал и ничего :frowning:

Видимо не зря он попал на Авито …

Не начинайте опять, датчик рабочий, он светится

Это лампочка светится. А сам датчик почему-то не обнаруживается. Кстати, может быть потому, что его подключали на 5 вольт вместо 3,3

1 лайк

Если я подключаю его на 3.3 то датчик тухнет

220 тогда надо !

2 лайка

Смирись, датчик скорее мертвый, чем живой. Во всех описаниях говорится, что питание у него 3,3В

Интересно, а я наоборот встречал, что надо 3.6 - 6В

Вот это делать опасно

Хм, а я чет думал, что он по прежнему мучает датчик из этой темы, а там он писал, что датчик AS608. Вот для того только 3,3В

Да, похоже уже “мучает” другой датчик))

P.S. Вот отличное описание с примерами
http://repository.umy.ac.id/bitstream/handle/123456789/22709/FPM10A.pdf?sequence=13&isAllowed=y

Не мешайте молодому! Он идет на… золотую медаль. :sweat_smile:

1 лайк

Пока в лауреатах на диплом